Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 16 days ago. Apr 14, 2025 - 14:00 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted 19 days ago. Apr 11, 2025 - 12:55 BST
Scheduled
We will be deploying the latest Connect release to the AU region during this time. As part of this update, Connect will be placed into maintenance mode briefly during the deployment window and you may notice a short period of downtime while the update is applied. Please read our release notes here https://jadu.featureos.app/changelog/jadu-connect-1-217
Posted 19 days ago. Apr 11, 2025 - 12:16 BST
This scheduled maintenance affected: Connect Australia (API, Background Processing, Search, Control Centre).