Verification is currently underway for the maintenance items.
Posted Mar 17, 2025 - 10:05 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2025 - 07:00 GMT
Scheduled
We will be deploying the latest Connect release to the UK, US, AU regions during this time - we do not expect any interruption to service. Please read our release notes here https://jadu.featureos.app/changelog/jadu-connect-1-214
Posted Mar 14, 2025 - 15:51 GMT
This scheduled maintenance affected: Connect UK (API, Background processing, Search, Control Centre), Connect US (API, Background processing, Search, Control Centre), and Connect Australia (API, Background Processing, Search, Control Centre).