Verification is currently underway for the maintenance items.
Posted Jan 12, 2026 - 11:07 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 12, 2026 - 08:00 GMT
Scheduled
As part of our ongoing commitment to maintaining a secure and reliable platform, we’re carrying out essential maintenance to upgrade the underlying technology that powers Jadu Connect.
This upgrade improves overall performance and strengthens security across the service. The work requires no downtime, and Jadu Connect will remain fully operational throughout.
Posted Jan 08, 2026 - 11:45 GMT
This scheduled maintenance affected: Connect UK (API, Background processing, Search, Control Centre).