Verification is currently underway for the maintenance items.
Posted Apr 16, 2025 - 05:38 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 16, 2025 - 05:00 BST
Scheduled
We will be deploying the latest Connect release to the UK region during this time. As part of this update, Connect will be placed into maintenance mode briefly during the deployment window and you may notice a short period of downtime while the update is applied. Please read our release notes here https://jadu.featureos.app/changelog/jadu-connect-1-217
Posted Apr 15, 2025 - 13:38 BST
This scheduled maintenance affected: Connect UK (API, Background processing, Search, Control Centre).