Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2025 - 08:00 GMT
Scheduled
We will be deploying the latest Connect release to the AUS region during this time - we do not expect any interruption to service. Please read our release notes here https://jadu.featureos.app/changelog/jadu-connect-1-215
Posted Mar 19, 2025 - 15:24 GMT
This scheduled maintenance affected: Connect Australia (API, Background Processing, Search, Control Centre).