Verification is currently underway for the maintenance items.
Posted Mar 24, 2025 - 21:40 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 24, 2025 - 21:30 GMT
Scheduled
We will be deploying the latest Connect release to the UK region during this time - we do not expect any interruption to service. This release contains internally raised bug fixes and minor improvements to the software.
Posted Mar 24, 2025 - 21:08 GMT
This scheduled maintenance affected: Connect UK (API, Background processing).