[UK] Background task outage - Time-in-status rule triggers
Incident Report for Connect
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 10:01 BST
Monitoring
We have now completed the re-running of time in status rules across all accounts (including UAT and PROD etc).

We will continue to monitor for any issues over the weekend.
Posted Apr 12, 2024 - 21:40 BST
Update
We are continuing to work through processing time in status rules across all accounts, and will provide a further update once we have completed this process.

There may be some further delays in background task processing whilst this work continues.
Posted Apr 12, 2024 - 17:55 BST
Update
We have now enabled time-in-status rule triggers and are currently working through processing the rules that have built up during this incident. This is on an account by account basis and it may take us some time to process your account rules, we'll provide a further update once we have finished processing all outstanding rules across all accounts.
Posted Apr 12, 2024 - 14:33 BST
Identified
We have identified the root cause of this issue and are working on a resolution and will provide a further update in due course.
Posted Apr 12, 2024 - 11:31 BST
Update
We have identified the potential root cause of this issue and are working to confirm and will provide a further update in due course.
Posted Apr 12, 2024 - 10:39 BST
Investigating
We have detected performance issues processing rules that use a Time-in-status trigger. We have currently paused the running of all such rules while a fix is being prepared.

The team will provide updates here as soon as we have more information.
Posted Apr 12, 2024 - 04:26 BST
This incident affected: Connect UK (Background processing).