Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 11, 2025 - 22:00 BST
Scheduled
We will be deploying the latest Connect release to the UK, US and AU regions during this time - we do not expect any interruption to service. This release contains internally raised bug fixes and minor improvements to the software.
Posted Jun 11, 2025 - 17:11 BST
This scheduled maintenance affected: Connect UK (API, Background processing), Connect US (API, Background processing), and Connect Australia (API, Background Processing).