This incident has been resolved. Our monitoring shows no new related failures in the past hour, and email delivery has returned to normal.
Posted Sep 04, 2026 - 17:04 BST
Monitoring
Mailgun, has confirmed that the underlying issue has been resolved. The incident originated with Microsoft and caused emails to Microsoft 365 recipients to be deferred with temporary "451 4.7.500 Server busy" responses. Delivery to other email providers was not affected. https://status.mailgun.com/
Deferred messages are being retried and are now processing normally. Some customers may still see a short delay while the backlog clears. We are continuing to monitor and will confirm once delivery has fully returned to normal.
Posted Sep 04, 2026 - 14:34 BST
Investigating
We are investigating reports of delayed or missing email deliveries.
Our email delivery provider, Mailgun, has reported an ongoing incident affecting email delivery. We have also identified messages failing with temporary "4.7.500 Server busy" responses from recipient mail systems.
This may result in delayed or undelivered emails for some customers. We are continuing to investigate and will provide further updates as more information becomes available.
Posted Sep 04, 2026 - 13:49 BST
This incident affected: Third Party Services (Mailgun Outbound Delivery).