Verification is currently underway for the maintenance items.
Posted Nov 18, 2024 - 20:45 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 18, 2024 - 20:00 GMT
Scheduled
We will be deploying the latest Connect release to the UK region during this time. This is a reschedule of the release deployment that was postponed this morning.
We are performing this maintenance out of hours in case of any brief interruption to service.