Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2025 - 09:00 BST
Scheduled
We will be undergoing scheduled maintenance of the Connect US region during this time. Connect will be placed into maintenance mode briefly during the maintenance window and you may notice a short period of downtime while the update is applied.
Posted Apr 15, 2025 - 08:43 BST
This scheduled maintenance affected: Connect US (API, Background processing, Search, Control Centre).