Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 03, 2026 - 08:00 GMT
Scheduled
We’re deploying security improvements to better align with modern infrastructure standards. There’s no change to how you access or use Jadu Connect as a result of this update.
Posted Feb 02, 2026 - 11:46 GMT
This scheduled maintenance affected: Connect UK (API, Background processing, Search, Control Centre), Connect US (API, Background processing, Search, Control Centre), and Connect Australia (API, Background Processing, Search, Control Centre).