Case export background process performance

Incident Report for Connect

Resolved

We are preparing to deploy a fix in the next release. We will continue to monitor the case export background process, which is currently stable.
Posted Aug 13, 2025 - 22:26 BST

Update

We have identified the underlying issue and are preparing a fix. Until then we will continue to monitor this background process and expand the worker pool to meet demand.
Posted Aug 13, 2025 - 21:52 BST

Update

The backlog is being processed and we are investigating the underlying issue.
Posted Aug 13, 2025 - 16:31 BST

Monitoring

Our background workers that process case exports are currently taking longer than usual. More workers have been created and team will provide any updates here.
Posted Aug 13, 2025 - 12:17 BST
This incident affected: Connect UK (API, Background processing, Search, Control Centre).