Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 31, 2025 - 07:45 BST
Scheduled
We will be undergoing scheduled maintenance of the Connect UK, US and AU regions during this time. We do not expect any interruption to service.
Posted Mar 27, 2025 - 15:03 GMT
This scheduled maintenance affected: Connect UK (API, Background processing, Search, Control Centre), Connect US (API, Background processing, Search, Control Centre), and Connect Australia (API, Background Processing, Search, Control Centre).